If you can read this text, theapplet is not working. Perhaps you don't have the Java 1.4.2 (or later) web plug-in installed?

Get Java here.